iCloud 同步指南(格志 3.2.0+)

在格志 3.2.0,我们使用 CloudKit 重写了 iCloud 同步功能,CloudKit 是苹果在 iOS 8 和 OS X 10.10(Yosemite)中推出的一项新技术。

对于大多数格志专业版用户,iCloud 同步在使用上还是跟以前一样——而且更快速更安全。但是在格志3.2.0中使用 iCloud 同步,有一些重要事项你应该知道——特别是当你不打算更新你所有的设备到最新的操作系统。请继续阅读了解所有细节。

什么是 CloudKit ?为什么它对格志是个好消息?

在 2012 年格志刚发布的时候就支持 iCloud 同步。在那时对于我们的用户来说同步是一个关键的功能,但当时的iCloud 还有很多不完善之处。在最早时期,iCloud 是被动的在后台运行,根据它自己的计划进行同步。如果因为任何原因导致用户数据库中的改变没有被 iCloud 收录,第三方程序将无法知道最后同步的数据是否最新的数据。

运行在 iOS 8 下的格志 3.2.0 所有这些都变了。因为有 CloudKit,我们再也不用被动等待 iCloud 服务来发送格志数据到你的所有设备。现在第三方应用可以直接连接到 iCloud 服务器,并控制何时获取数据。最终使得格志 3.2.0 中的新的 iCloud 同步比之前的同步更快、更智能也更稳定。

使用最新的 iCloud 服务有什么要求?
  • iPhone 4s 或更新的设备,iPad 2 或更新的设备
  • iOS 8
  • 格志 3.2.0

如果我在格志 3.2.0 之前就使用了 iCloud 同步,升级之后我的数据库会合并到新的同步系统中吗?

不会。你将会自动断开旧的 iCloud 同步,所有的数据将会安全的迁移到本地。你必须在格志的设置界面里手动打开新的 iCloud 同步。

如果你购买了一个已经安装了 iOS 8 的新设备(如:iPhone 6),请务必在设置你的新设备之前,升级你的旧设备,并将数据同步到 iCloud。

格志 3.2.0 是否可以通过 iCloud 与老版本的格志进行数据同步?

格志 3.2.0 完全重写了 iCloud 相关的功能,新的实现方式和旧版本无法兼容。如果你在一台设备上更新格志到 3.2.0,这台设备只能和其它同样升级到格志 3.2.0 的设备之间进行同步。

我已经升级了我的所有设备并且阅读了这里的常见问题,但是格志还是无法使用 iCloud 进行同步。求情帮助!

不必担心—我们可以提供帮助。请从以下故障排除步骤开始:
  1. 确保你已经升级到最新的格志。(只有升级到 iOS 8,App Store 上才会出现更新信息)
  2. 确保 iCloud Drive 是开启状态。
  3. 参考这里的步骤:iCloud 同步问题排查清单
  4. 如果是仍旧无法解决,推荐使用坚果云替换同步服务,已获得更好的同步速度和稳定性。附传送门
如果你完成了上述步骤的检查,还是无法顺利同步,请和我们取得联系,我们很乐意提供帮助。请务必让我们知道您已阅读过这篇文章。



Feedback and Knowledge Base